• Witaj na Forum Arduino Polska! Zapraszamy do rejestracji!
  • Znajdziesz tutaj wiele informacji na temat hardware / software.
Witaj! Logowanie Rejestracja


Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
HMC5883l uszkodzony?
#1
Witam,
Zakupiłem w sklepie botland magnetometr GY-273 HMC5883L. Moduł ten posiadał w zestawie piny do samodzielnego zlutowania. Po zlutowaniu wszystkiego, moduł podłączyłem do mojego Arduino Nano. Wgrałem najprostszy program, który jest tutaj https://botland.com.pl/content/149-3-osi...-i-arduino. Niestety jako wyniki otrzymuję tylko i wyłącznie zera:
Cytat:x: 0, y: 0, z: 0

Skorzystałem również z biblioteki i kodu zamieszczonego na http://www.jarzebski.pl/arduino/czujniki...5883l.html. Tam w odpowiedzi dostaję komunikat:
Cytat:Nie odnaleziono HMC5883L, sprawdz polaczenie!
Pierwsza moja myśl, że może źle zlutowałem piny i nie ma w którymś miejscu połączenia. Po chwili pomiarów miernikiem stwierdziłem, że wszystkie połączenia są jak najbardziej sprawne. Nawet bezpośrednio na układzie odczytuję napięcie ok 4,5v (przy 5v z Arduino). Kolejna myśl - może uszkodziłem moduł przy lutowaniu?  Sad Jest to w ogóle możliwe? Dla mnie moduł wygląda niestety na uszkodzony, ale wolę zasięgnąć Waszej opinii bo być może się mylę.
 
#2
Sprawdź, czy na pewno tam siedzi HMC, czy może QMC?
Jeśli QMC, to zmień bibliotekę:
https://github.com/mechasolution/Mecha_QMC5883L
Nie trzeba dawać punktów za pomoc, ale jeśli problem został rozwiązany, proszę o tym poinformować w ostatnim poście.

[Obrazek: SsIndaG.jpg]
 
#3
Rzeczywiście ta druga biblioteka zadziałała. Dziękuję! Chociaż nie rozumiem tego bo na module jest nadruk HMC5883L. To trochę wprowadza w błąd.
 
  


Skocz do:


Przeglądający: 1 gości