• Witaj na Forum Arduino Polska! Zapraszamy do rejestracji!
  • Znajdziesz tutaj wiele informacji na temat hardware / software.
Witaj! Logowanie Rejestracja


Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Komp nie widzi Arduino Mega 2560
#1
Hej

No trafi mnie coś po prostu.

Podłączam Arduino Mega 2560 R3 do kompa i NIC, nie kuma.
Używałem go wcześniej i nie było problemów, teraz się zesrało...

Płytka to dokładny klon - zamiast FTDI jest Atmega 16, nie to chińskie dziadostwo...

Wkładam we wszystkie porty po kolei - nie pomaga...

Macie może pomysł co z tym zrobić? Poza kupieniem nowej?

Jakub
 
Odpowiedź
#2
Atmega16 zastosowana jako konwerter UART-USB nie daje wielkiej przewagi modułowi, ot pozwala na własne przerobienie kodu w razie potrzeby np. na joystick USB, gdy ktoś ma humor, ale typowe układy FTDI, CH340 czy CP2102 sprawdzają się tu równie dobrze, a popularność sprawia, że sterowniki są często już w systemie lub wyszukiwane automatycznie.
Podłącz się programatorem pod złącze ICSP Atmega16u2 i sprawdź czy uC jest sprawny. Potem jeśli tak, sprawdź elementy na płytce, przede wszystkim zasilanie - ogólnie wystarczy ponowny odczyt bez podania zasilania na Atmegę z programatora. Jak znajdziesz jakieś kłopoty to daj znać.
 
Odpowiedź
#3
Grubsza sprawa.

Nie jestem w stanie połączyć się z ATmega16U2 na płytce Mega 2560.
Z parametrem -F odczytuje sygnatury losowe(?) 0xf80000, 0x00ffff, 0x00ff00, 0x000000.

Wygląda na to, że kicha...

Ps. Zauważyłem, że gdy płytka podłączona jest do zasilacza i wtedy podłączyć USB to melduje 
się nowe urządzenie w systemie, niestety jako "nieznane" co niewiele daje Wink

J.
 
Odpowiedź
  


Skocz do:


Przeglądający: 1 gości