• Witaj na Forum Arduino Polska! Zapraszamy do rejestracji!
  • Znajdziesz tutaj wiele informacji na temat hardware / software.
Witaj! Logowanie Rejestracja


Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Problem z silnikiem krokowym Nema 17 (17HS4401)
#1
Cześć,

planuję złożyć prosty procesor do wywoływania zdjęć analogowych (coś na wzór Jobo Cpe2)

Pierwszym etapem jest mechanizm obracający koreks (pudełko z chemią na kliszę). Postanowiłem zbudować go na bazie ARDUINO UNO R3 ATMEGA328 CH340 AVR + Sterownik L298N + silnik krokowy Nema 17
Całość podłączyłem wg schematu, który znalazłem pod tym linkiem. Użyłem również tamtejszego skryptu.


Kod:
https://lastminuteengineers.com/stepper-motor-l298n-arduino-tutorial/



Jednak bazowa wartość 
Kod:
const int stepsPerRevolution = 200;




powoduje, że silnik działa tak:

Kod:
https://youtu.be/QDJ-_r9COxo


1. Dopiero zmiana na 300 i zostawienie tylko jednego kierunku obrotu daje płynną pracę silnika. Jakakolwiek próba zmiany RPMów poniżej 60 powoduje, ze silnik przestaje się kręcić albo kręci się tak jak chce. 

2. Nawet jeśli spr=300 i rmp=60 pozwalają silnikowi obracać się płynnie w jednym kierunku to po kilku minutach ciągłej pracy zaczyna wariować i działać jak chce - trochę tak jak w pkt poniżej

3.  Przy dwóch kierunkach obrotu silnik nie zawsze obraca się prawidłowo. Np wykonuje obrót CW, ale CCW już stoi w miejscu, albo dziwnie "skacze" żeby następnie CW obrócić poprawnie.

Zastanawiam się co może być problemem: silnik czy podłączenie, czy sterownik silnika.
 
Odpowiedź
#2
Upewnij się, że masz zasilacz odpowiedniej mocy i użyj biblioteki Accelstepper. A jak już będziesz miał tę bibliotekę to zobacz czy taki dedykowany do krokowców sterownik nie będzie lepszy https://botland.com.pl/pl/sterowniki-sil...35v2a.html.
 
Odpowiedź
  


Skocz do:


Przeglądający: 1 gości