• Witaj na Forum Arduino Polska! Zapraszamy do rejestracji!
  • Znajdziesz tutaj wiele informacji na temat hardware / software.
Witaj! Logowanie Rejestracja


Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Problem z zewnętrznym zasilaniem atmega328
#11
(15-05-2019, 20:49)kaczakat napisał(a): W loop możesz dodać jeszcze millis i co 1s migać led, sprawdzisz czy loop się wykonuje, choć zdziwiłbym się gdyby nie. Pewnie nie działa komunikacja z BT, sprawdź czy jest wspólna masa.

Udało się gdy przeniosłem na Serial sprzętowy, faktycznie musiało być coś nie tak z komunikacją BT, akurat może korzystać z sprzętowego nie przeszkadza mi to. Przy okazji jeszcze zapytam o to zasilanie. Mam 2 zasilacze jeden 5V i drugi 6V, z tego 5V chciałbym zasilać ATmegę + HC-05 a z 6V same serwomechanizmy. Czyli masy obu zasilaczy robię wspólną masę tak? Czy potrzebne będą jeszcze jakieś kondensatory do filtrowania napięcia na ten zasilacz 6V - serwa?
I jeszcze raz dzięki za pomoc w rozwiązaniu poprzedniej kwestii Smile
 
Odpowiedź
#12
Wszystkie urządzenia, które się ze sobą komunikują muszą mieć wspólną masę, chyba że sygnał przesyłasz optycznie.
Co do kondensatorów dołożenie raczej nie zaszkodzi, przy Atmedze minimum to 3 szt. ceramiczne zaraz przy pinach zasilania i Vref + ewentualnie elektrolityczne.
 
Odpowiedź
#13
Witaj. Tylko i wyłącznie kwestia zasilania. Zasilanie serw osobno i arduino też osobno. Wszystkie masy razem i musi działać nie ma siły. Pamiętaj też że zasilanie serwomechanizmów musi mieć dość wysoką wydajność prądową +- 0.5A.
Pamiętaj o WSPÓLNYCH MASACH!!
 
Odpowiedź
  


Skocz do:


Przeglądający: 1 gości